×
Menu
Index

Design a Detail Report

 
The following steps walk a user, with write access to the module and architecture, through creating a Detail report in Reporter. This example uses an architecture based on the Risk Analysis Framework.

1. After a new report has been created, it must be designed. Ensure you are in the Report Designer pane of the Outlook Bar. Locate the newly created report in the tree view (under the Risk Data viewpoint in this example).
 
2. You first need to change the report type. In the Home tab of the Ribbon Bar, find and select Detail in the Report Type gallery. A confirmation window appears. Click OK to change the report type.
 
3. In the Report Details group of the Home tab, rename the report. The report name changes in the Outlook Bar once you click off of the Name field. Add a description in the Description field if desired.
 
4. New reports, and reports where the type was changed, are initialized without any nodes or relationships added. There are two parts to designing a Detail report: the setup (to select the data) and the template (to design the layout). This report brings in data from the Risk and Risk Mitigation nodes, with the Risk node as the primary starting point.
 
5. To build the setup, click the Add Element button in the Configuration group of the Ribbon Bar Home tab. This adds the elements to the Data Source Setup tab in the Content Pane.
 
6. Select the element in the Content Pane, and click the pencil icon in the upper right-hand corner to edit it. This is the primary element—all other elements must use or start from the node selected here. (NOTE: The first element in the list does not have to be the primary element.) Complete the Info and Source Data tabs with the information shown. Click the Save button when finished.
 
7. Click Add Element again, and enable editing. This element uses the same node as the primary element, so you do not need to add a path to get to our data. Complete the Info and Source Data tabs with the information shown. Click Save when finished.
 
8a. The third element will bring in the mitigations, which are in the Risk Mitigation node and not the Risk node. To get to this data, you need to create a path from the Risk node to the Risk Mitigation node (you can use
the relational diagrams to see this). All paths must start in the node you selected as primary (the Risk node in step 6). Select the Risk Name element. In the Ribbon Bar, click the Copy Element button. This creates an exact copy of the element.
 
8b. Select your copy and enable editing. Change the name in the Info tab. Uncheck the Primary box in the Source Data tab. Save the element when you are finished.
 
8c. The next step starts the path from the Risk node to the Risk Mitigation node by finding the risk name in the Risk Mitigation node: the Risk element. Ensure your Mitigations element is selected. In the Ribbon Bar, click Add Path to add a path to your element.
 
8d. Select the SubElement and edit it. Complete the Info and Source Data tabs with the information shown. Click Save when finished.
 
8e. The final step takes you from the risk to the mitigation name. With the "to Risk Mitigation node" SubElement selected, click Add Path again from the Ribbon Bar. Select this SubElement and edit it. Complete the Info and Source Data tabs with the information shown. Click Save when finished.
 
9. Click the Save Report button in the Ribbon Bar to save the entire report design.
 
10. Now that the data setup is complete, you need to design the layout of the report—this is what is displayed in the Report Viewer pane. Select the Report Template tab in the Content Pane. Click in the page and type a title. If desired, you can change the font formatting in the Edit tab, and the margin and page orientation in the Page Layout tab.
 
11. A Detail report puts each primary element on a new page. This example has the risk name at the top, and uses the mail merge functionality to bring in the data for this element. Select the Mailings tab of the Ribbon Bar. Click on the Insert Merge Field button. From the pull-down menu, select Risk Name.
 
This added the merge field at the point of the cursor in the page:
 
12. Follow step 11 to add the two other elements in. The finished merge field layout should look similar to the screenshot.
 
13. Click the Save Report button again in the Home tab of the Ribbon Bar.
 
14. The SAR RAM data was used for these next visualization steps. Select the Report Viewer pane in the Outlook Bar. In the Home tab of the Ribbon Bar, click the Refresh Report button to generate the report. A busy indicator displays as elements and paths are built.
 
15. The final report should match the design and formatting of the layout and data elements. To save a cached version of what is displayed in the Report Viewer pane, return to the Report Designer pane. Click Save Report in the Home tab of the Ribbon Bar.
© 2019 Exostrategies, Inc.