×
Menu
Index

Design an AV-2 Dictionary Report

 
The following steps walk a user, with write access to the Reporter module and architecture, through designing an AV-2: Integrated Dictionary report, using the Dictionary report type.

1. After a new report has been created, we need to design it. Ensure you are in the Report Designer pane of the Outlook Bar. Locate the newly created report in the tree view (under the AV-2 viewpoint in our example).
 
2. The default report type is Class, so first we need to change it. In the Home tab of the Ribbon Bar, find and select Dictionary in the Report Type gallery (you can use the arrows to scroll through the menu).
 
3. A confirmation window appears. Click OK to change the report type.
 
4. In the Report Details group of the Home tab, rename the report. The report name changes in the Outlook Bar once you click off the Name field. If desired, add a description in the Description field.
 
5. New reports, and reports where the type was changed, are initialized without any nodes or relationships added. There are two parts to designing a Dictionary report: the setup (to select the data) and the template (to design the layout). An AV-2 is composed of the architecture's definitions, and includes as many (or as few) nodes as you prefer. In this example, we define three nodes: Actual Project, Capability, and Enterprise Phase.
 
6. To build the setup, click Add Definition three times from the Configuration group in the Home tab of the Ribbon Bar. This adds the definitions to the Data Source Setup tab in the Content Pane.
 
7. Select the first definition in the Content Pane. Click the pencil icon in the upper right corner to edit it. Complete the Info, Source Data, and Date Attributes tabs with the information shown below. Click Save when finished.
 
8. Select the second definition and edit it. Complete the Info, Source Data, and Date Attributes tabs with the information shown below. Click Save when finished.
 
9. Select the third definition and edit it. Complete the Info, Source Data, and Date Attributes tabs with the information shown below. Click Save when finished.
 
10. Click the Save Report button in the Home tab of the Ribbon Bar to save the entire report design.
 
11. Now that the data setup is complete, we need to design the layout of the report—this is what will be seen in the Report Viewer pane. Select the Report Template tab in the Content Pane. Click in the page and type a report header. If desired, you can change the font formatting in the Edit tab and the margin and page orientation in the Page Layout tab.
 
12. Next, we need to insert our table. Select the Insert tab in the Ribbon Bar. Click the Table button, and create a table with five columns and two rows. The columns are for the data; the rows are for the titles (step 13) and merge elements (step 14).
 
13. In the table, type the data titles in the first row. You can adjust the column widths (like in Microsoft Word) and change the font, as desired. Use the Table Design tab of the Ribbon Bar to quickly change the visual styling of the table; however, too much styling may slow down the generation and loading of the report.
 
14. We use a mail merge feature to bring in the data for each column. Click in the second row of the first column (under the title). Select the Mailings tab of the Ribbon Bar. Click the Insert Merge Field button. From the pull-down menu, first select Name.
 
This added the merge field at the point of the cursor in the table:
 
15. Follow step 14 to add the other four merge fields. The finished table should look similar to the screenshot.
 
16. Click the Save Report button again in the Home tab of the Ribbon Bar.
 
17. We used the SAR EA data for these next visualization steps. Select the Report Viewer pane in the Outlook Bar. In the Home tab of the Ribbon Bar, click the Refresh Report button to generate the report. A busy indicator displays as the definitions are retrieved.
 
18. The final report should match the design and formatting of the layout and data elements. To save what is shown in the Report Viewer pane, return to the Report Designer pane. Click Save Report again in the Ribbon Bar.
© 2019 Exostrategies, Inc.