×
Menu
Index

Design an OV-1 Object Diagram

 
The following steps walk a user, with write access to the Reporter module and architecture, through designing an OV-1: High-Level Operational Graphic report, using the Object report type.

1. After a new report has been created, we need to design it. Ensure you are in the Report Designer pane of the Outlook Bar. Locate the newly created report in the tree view (under the OV-1 viewpoint in our example).
 
2. The default report type is Class, so first we need to change it. In the Home tab of the Ribbon Bar, find and select Object in the Report Type gallery (you can use the arrows to scroll through the menu).
 
3. A confirmation window appears. Click OK to change the report type.
 
4. In the Report Details group of the Home tab, rename the report. The report name changes in the Outlook Bar once you click off of the Name field. If desired, add a description in the Description field.
 
5. New reports, and reports where the type was changed, are initialized without any nodes or relationships added. An OV-1 provides a summary-level depiction of a mission; our OV-1 brings in data from the Concept Role and Arbitrary Connector nodes. Click Add Node in the Configuration group of the Ribbon Bar—this adds the node to the Data Source Setup tab in the Content Pane.
 
6. Our node brings in the concept roles involved in the operational concept. Select the node in the Content Pane, and click the pencil icon in the upper right corner to enable editing. Complete the Info, Model Data, and Date Attributes tabs with the information shown below. Click the Save button when finished.
 
7. Click the Save Report button in the Ribbon Bar to save the report design.
 
8. Click the Add Relationship button to add the relationships to the Data Source Setup tab.
 
9. The relationship defines the connection between concept roles and the data passed between them. Select it in the Content Pane, and click the pencil icon to edit. Complete the Info and Source Data tabs with the information shown below (dates are not as important for relationships, but you can fill out the Date Attributes tab if desired). Click Save.
 
10. We want our report to only show objects with connections. Select the Data tab in the Ribbon Bar. Click the Remove Orphans button to enable it (it turns orange). When the report is generated in the Report Viewer pane, we will not see any unconnected objects.
 
11. Select the Home tab again. Click Save Report in the Ribbon Bar.
 
12. We used the SAR EA data for these next visualization steps. Select the Report Viewer pane in the Outlook Bar. In the Home tab of the Ribbon Bar, click the Refresh Diagram button to generate the report.
 
13. You can save a cached version of this image for others to see by clicking the Save to Database button in the Ribbon Bar. In this example, we will use the built-in tools to make the diagram more readable.
 
14. To change the layout option, select the Layout tab in the Ribbon Bar. In the Layout gallery, select Vertical (Sugiyama).
 
15. Our objects are lined up better, but now we need to adjust the spacing between them. In the Separation group, choose a high value for Horizontal (we used 80 px for our example).
 
16. To change the routing option, select the Routing tab. In the Routing gallery, we chose Parallel to separate the start and end points of the lines.
 
17. You may need to click Refresh Diagram again (in the Home tab) to fully see the separation. Be sure to click Save to Database when you are finished to ensure others see your changes.
© 2019 Exostrategies, Inc.