×
Menu
Index

Design an OV-5b Activity Diagram

 
The following steps walk a user, with write access to the Reporter module and architecture, through designing an OV-5b: Operational Activity Model report, using the Activity report type.

1. After a new report has been created, we need to design it. Ensure you are in the Report Designer pane of the Outlook Bar. Locate the newly created report in the tree view (under the OV-5b viewpoint in our example).
 
2. We need to change the report type from the default of Class. In the Home tab of the Ribbon Bar, find and select Activity in the Report Type gallery. A confirmation window appears. Click OK to change the report type.
 
3. In the Report Details group of the Home tab, rename the report. The report name changes in the Outlook Bar once you click off of the Name field. If desired, add a description in the Description field.
 
4. New reports, and reports where the type was changed, are initialized without any nodes or relationships added. An OV-5b describes relationships among activities and resources exchanged between activities. Click Add Node, in the Configuration group of the Ribbon Bar, four times. This adds the nodes to the Data Source Setup tab in the Content Pane.
 
5. The first node sets the high-level activity to model (SAR EA data used in our example); select it in the Content Pane. Click the pencil icon in the upper right corner to enable editing. Complete the Info, Model Data, Date Attributes, and Filter tabs with the information shown below. Click Save.
 
6. Select the second node; this brings in the nodes that will perform the operational activities. Click the pencil icon to enable editing. Complete the Info, Source Data, and Date Attributes tabs with the information shown below. Click Save when finished.
 
7. Select the third node; this brings in the operational parameters, which are the products either used by or produced by the operational activity. Click the pencil icon to enable editing. Complete the Info, Source Data, and Date Attributes tabs with the information shown below. Click Save when finished.
 
8. Select the fourth node; this brings in the lower-level activities associated with the parent activity in the first node. Click the pencil icon to enable editing. Complete the Info, Source Data, and Date Attributes tabs with the information shown below. Click Save when finished.
 
9. In the Home tab of the Ribbon Bar, click the Save Report button to save the entire report design.
 
10. Now we need to define the different relationships. Click Add Relationship four times in the Ribbon Bar. This adds them to the Data Source Setup tab.
 
11. Our first relationship defines the operational parameters being used by (input) the operational activities. Select it in the Content Pane, and click the pencil icon to enable editing. Complete the Info and Source Data tabs with the information shown below (dates are not as important for relationships; you can fill out the Date Attributes tab if desired). Click Save when finished.
 
12. Select the second relationship in the Content Pane; this defines the operational parameters being produced by (output) the operational activities. Complete the Info and Source Data tabs with the information shown below. Click the Save button when finished.
 
13. Select the third relationship in the Content Pane; this defines the flow between the operational activities. Complete the Info and Source Data tabs with the information shown below. Click the Save button when finished.
 
14. Select the fourth relationship in the Content Pane; this defines which nodes perform which operational activities. Complete the Info and Source Data tabs with the information shown below. Click the Save button when finished.
 
15. Click Save Report in the Ribbon Bar.
 
16. We used the SAR EA data for these next visualization steps. Select the Report Viewer pane in the Outlook Bar. In the Home tab of the Ribbon Bar, click the Refresh Diagram button to generate the report.
 
16. You can save a cached version of this image for others to see by clicking the Save to Database button in the Ribbon Bar. In this example, we will use the built-in tools to make the diagram more readable.
 
17. To change the routing option, select the Routing tab. In the Routing gallery, we chose Straight to draw the lines directly between objects. You may need to click Refresh Diagram again to readjust the start and end points of the lines.
 
18. Some of the lines between objects are hard to see; we can adjust the spacing between objects in the Layout tab. In the Separation group, increase the value for Horizontal (we used 30 px in our example). Be sure to click Save to Database when you are finished to ensure others see your changes.
© 2019 Exostrategies, Inc.