×
Menu
Index

Design an OV-6c Sequence Diagram

 
The following steps walk a user, with write access to the Reporter module and architecture, through designing an OV-6c: Operational Event-Trace Description report, using the Sequence report type.

1. After a new report has been created, we need to design it. Ensure you are in the Report Designer pane of the Outlook Bar. Locate the newly created report in the tree view (under the OV-6c viewpoint in our example).
 
2. We need to change the report type from the default of Class. In the Home tab of the Ribbon Bar, find and select Sequence in the Report Type gallery (you can use the arrows to scroll through the menu). A confirmation window appears. Click OK to change the report type.
 
3. In the Report Details group of the Home tab, rename the report. The report name changes in the Outlook Bar once you click off of the Name field. If desired, add a description in the Description field.
 
4. New reports, and reports where the type was changed, are initialized without any nodes or relationships added. An OV-6c defines interactions and traces actions in a scenario; first, we need to bring in the scenario performers. Click Add Node once in the Configuration group of the Ribbon Bar. This adds the node to the Data Source Setup tab in the Content Pane.
 
5. Our node brings in our scenario performers, which are found in the Node node. Select the node in the Content Pane, and click the pencil icon in the upper right corner to enable editing. Complete the Info, Model Data, and Date Attributes tabs with the information shown below. Click the Save button when finished.
 
6. In the Home tab of the Ribbon Bar, click the Save Report button to save the entire report design.
 
7. Now we need to define the messages and items passed between the performers. Click Add Relationship two times in the Ribbon Bar. This adds them to the Data Source Setup tab.
 
8. Our first relationship defines the messages passed between nodes, along with the order they are passed. Select the first relationship in the Content Pane, and click the pencil icon to edit it. Complete the Info, Source Data, and Filter tabs with the information shown below (dates are not as important for relationships; you can fill out the Date Attributes tab if desired). Click Save when finished.
 
9. Select the second relationship and edit it. This defines the items exchanged between nodes, along with the order they are exchanged. Complete the Info, Source Data, and Filter tabs with the information shown below. Click Save when finished.
 
10. Click the Save Report button in the Ribbon Bar again.
 
11. The SAR EA data was used for this visualization step. Select the Report Viewer pane in the Outlook Bar. In the Home tab of the Ribbon Bar, click the Refresh Diagram button to generate the report. Note that a sequence diagram only has the Sequence layout (in the Layout tab of the Ribbon Bar) and Straight router (in the Routing tab) available as options, and they are automatically selected when the report is generated.
 
12. You can save a cached version of this image for others to see by clicking the Save to Database button in the Ribbon Bar.
© 2019 Exostrategies, Inc.