×
Menu
Index

Design an SV-10b State Diagram

 
The following steps walk a user, with write access to the Reporter module and architecture, through designing an SV-10b: Systems State Transition Description report, using the State report type.

1. After a new report has been created, we need to design it. Ensure you are in the Report Designer pane of the Outlook Bar. Locate the newly created report in the tree view (under the SV-10b viewpoint in our example).
 
2. We need to change the report type from the default of Class. In the Home tab of the Ribbon Bar, find and select State in the Report Type gallery (you can use the arrows to scroll through the menu). A confirmation window appears. Click OK to change the report type.
 
3. In the Report Details group of the Home tab, rename the report. The report name changes in the Outlook Bar once you click off of the Name field. If desired, add a description in the Description field.
 
4. New reports are initialized without any nodes or relationships added. Select Add Node two times from the Configuration group in the Ribbon Bar. This adds the nodes to the Data Source Setup tab in the Content Pane.
 
5. Select the first node in the Content Pane to configure it. This node brings in the resource states, the building blocks of our diagram. Click the pencil icon in the upper right corner to edit it. Complete the Info, Source Data, and Date Attributes tabs with the information shown below. Click Save.
 
6. Select the second node and edit it. This brings in the functions performed at each state. Complete the Info, Source Data, and Date Attributes tabs with the information shown below. Click Save.
 
7. Click the Save Report button in the Ribbon Bar.
 
8. Select Add Relationship from the Configuration group in the Ribbon Bar. This adds the relationship to the Data Source Setup tab in the Content Pane.
 
9. Select the relationship in the Content Pane. Click the pencil icon in the upper right corner to edit it. Complete the Info, Source Data, and Filter tabs with the information shown below (dates are not as important for relationships; you can fill out the Date Attributes tab if desired). Click Save. (Our example uses SAR EA data; complete the Filter tab with the name of your case from the Resource State Description node.)
 
10. In the Ribbon Bar, click the Save Report button again.
 
11. We used the SAR EA data for these next visualization steps. Select the Report Viewer pane in the Outlook Bar. In the Home tab of the Ribbon Bar, click the Refresh Diagram button to generate the report.
 
12. You can save a cached version of this image for others to see by clicking the Save to Database button in the Ribbon Bar. In this example, we will use the built-in tools to make the diagram more readable.
 
13. To change the auto color options, select the Edit tab of the Ribbon Bar. In the Auto Color group menu, choose By ZIndex. This colors the objects by layer.
 
14. To change the routing option, select the Routing tab. In the Routing gallery, we chose Gliding to draw the lines directly between objects.
 
15. You can also manually arrange the containers and shapes if desired, or change other layout settings. Be sure to click Save to Database (in the Home tab) when you are finished to ensure others see your changes.
© 2019 Exostrategies, Inc.