×
Menu
Index

Design an SV-7 Table Report

 
The following steps walk a user, with write access to the Reporter module and architecture, through designing an SV-7: Systems Measure Matrix report, using the Table report type.

1. After a new report has been created, we need to design it. Ensure you are in the Report Designer pane of the Outlook Bar. Locate the newly created report in the tree view (under the SV-7 viewpoint in our example).
 
2. The default report type is Class, so first we need to change it. In the Home tab of the Ribbon Bar, find and select Table in the Report Type gallery (you can use the arrows to scroll through the menu).
 
3. A confirmation window appears. Click OK to change the report type.
 
4. In the Report Details group of the Home tab, rename the report. The report name changes in the Outlook Bar once you click off of the Name field. If desired, add a description in the Description field.
 
5. New reports, and reports where the type was changed, are initialized without any nodes or relationships added. There are two parts to designing a Table report: the setup (to select the data) and the template (to design the layout). An SV-7 specifies qualitative and quantitative measures (i.e., metrics) of resources; our report uses data from the Measurement node and the Systems Resource node. Our report uses the Measurement node as the primary (or initial) starting point.
 
6. To build the setup, click Add Element four times from the Configuration group in the Home tab of the Ribbon Bar. This adds the elements to the Data Source Setup tab in the Content Pane.
 
7. Select the first element in the Content Pane, and click the pencil icon in the upper right corner to edit it. This is our primary element—all other elements must use or start from the node selected here. (NOTE: The first element in the list does not have to be the primary element.) Complete the Info and Source Data tabs with the information shown below. Click the Save button when finished.
 
8. Select the second element and edit it. This element uses the same node as our primary element, so we do not need to add a path to get to our data. Complete the Info and Source Data tabs with the information shown below. Click Save when finished.
 
9. Select the third element and edit it. This element also uses the same node as our primary element, so a path is not needed here either. Complete the Info and Source Data tabs with the information shown below. Click Save when finished.
 
10. Our fourth element brings in our resources, which are in the System Resource node and not the Measurement node. To get to this data, we need to create a path from the Measurement node to the System Resource node. We know that the measurement is used in the System Resource node (by using relational diagrams or Use Reference Helper); therefore, this element needs to start with the Measurement Name. Complete the Info and Source Data tabs with the information shown below. Click Save when finished.
 
10a. The next step starts the path from the Measurement node to the System Resource node, by finding the measurement name in the System Resource node: the Property element. In the Ribbon Bar, click Add Path. This adds a new path under the selected element. Select this SubElement and edit it. Complete the Info and Source Data tabs with the information shown below. Click Save when finished.
 
10b. The final step takes us from the measurement to the resource name. With the "to SR table" SubElement selected, click Add Path again from the Ribbon Bar to add our final path. Select this SubElement and edit it. Complete the Info and Source Data tabs with the information shown below. Click Save when finished.
 
11. Click the Save Report button in the Home tab of the Ribbon Bar to save the entire report design.
 
12. Now that the data setup is complete, we need to design the layout of the report—this is what will be seen in the Report Viewer pane. Select the Report Template tab in the Content Pane. Click in the page and type a report header. If desired, you can change the font formatting in the Edit tab, and the margin and page orientation in the Page Layout tab.
 
13. Next, we need to insert our table. Select the Insert tab in the Ribbon Bar. Click the Table button, and create a table with four columns and two rows. The columns are for the four elements (from the Data Source Setup tab); the rows are for the titles and merge elements (steps 14 and 15).
 
14. In the table, type in element titles for the first row. You can adjust the column widths (like in Microsoft Word) and change the font, as desired. Use the functionality in the Table Design tab of the Ribbon Bar to change the visual styling of the table.
 
15. We use a mail merge feature to bring in data for each column. Click in the second row of the first column (under the title). Select the Mailings tab of the Ribbon Bar. Click on the Insert Merge Field button. From the pull-down menu, select Measurement.
 
This added the merge field at the point of the cursor in the table:
 
16. Follow step 15 to add the other three merge fields. The finished table should look similar to the screenshot.
 
17. Click the Save Report button again.
 
18. We used the SAR EA data for these next visualization steps. Select the Report Viewer pane in the Outlook Bar. In the Home tab of the Ribbon Bar, click the Refresh Report button to generate the report. A busy indicator displays as the elements and paths are built.
 
19. The final report should match the design and formatting of the layout and data elements. To save what is shown in the Report Viewer pane, return to the Report Designer pane. Click Save Report in the Home tab of the Ribbon Bar.
© 2019 Exostrategies, Inc.